Cobblers Children

Its an old phrase that "the cobblers children have the worst shoes".. And so today during a routine (but often skipped) inspection of my own server, I find that its running Domino v6.5, and sametime v6.5.1.. A quick upgrade to v6.5.2 is in order, methinks.

However stupid this appears (lots!), it does confirm that this Domino stuff is incredibly idiot tolerant and stable. Nice.

Try doing *that* with Microsoft Exchange...